It is currently Tue Oct 16, 2018 11:34 pm


SS-Waldorf

Where to share your BC Modular creations
  • Author
  • Message
Offline
User avatar

w_ellis

  • Posts: 627
  • Joined: Sat Apr 13, 2013 5:38 pm

SS-Waldorf

PostTue Mar 11, 2014 10:20 am

Hi all,

I thought I'd start putting together some example patches using the ScopeSync modules that were included in 0.975b and here's the first (very simple) one, which is just a basic synth using the Waldorf Wavetable Oscillator. If you don't have Max For Live, you can still use this patch, just re-patch the MIDI input into the MVC, instead of the MIDI Out of the SS16.

SS-Waldorf.zip
Scope Dev + Max For Live patch
(890.81 KiB) Downloaded 373 times


Please make sure to follow the ScopeSync installation instructions found here before using this patch, as it relies on our Max java package being available: http://bcmodular.wikispaces.com/ScopeSync

Thanks,
Will

P.S. I'm no modular expert, so any mistakes you spot, feel free to point them out!

Some screenshots:
Screenshot 2014-03-11 09.42.25.png
Screenshot 2014-03-11 09.42.25.png (29.78 KiB) Viewed 10621 times

Screenshot 2014-03-11 09.42.12.png
Screenshot 2014-03-11 09.42.12.png (20.44 KiB) Viewed 10621 times

Screenshot 2014-03-11 09.42.04.png
Screenshot 2014-03-11 09.42.04.png (73.74 KiB) Viewed 10621 times

Screenshot 2014-03-11 09.42.01.png
Screenshot 2014-03-11 09.42.01.png (122.8 KiB) Viewed 10621 times
Offline
User avatar

cwmod

  • Posts: 280
  • Joined: Wed Oct 30, 2013 5:16 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 11:02 am

Hi w_ellis!
sorry I can't get it to work.
In Able, I loaded the m4l ss-waldorf patch, ok.
In Scope, I loaded the SSWaldorf modular patch, ok.
In Able, I configuered the output to ext 7+8, ok.
In Scope, I connected Asio 5L/R to the patch In1 and 2...
and then I got an error message in Able, lost all Asio connections and afterwards a BSOD.
Do you have an idea what I did wrong?

btw, after loading the SS-Waldorf patch into Scope, I got an error message because of missing dsp file: MIDI MultiMerge 2, which I found in my ScopeSdk (it's the MMuMrg2.dsp file)

Bad that it doesn't work cause controlling Scope diretly in Ableton would be super cool!
Offline
User avatar

w_ellis

  • Posts: 627
  • Joined: Sat Apr 13, 2013 5:38 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 11:46 am

Hi Roy,

Shouldn't you connect 4l/r if you use ext 7/8 from Ableton?

Which versions of ableton, max, java and windows are you running?

I'm sure we'll be able to get it running for you. It's not that clever :-)

Thanks,
Will
Offline
User avatar

w_ellis

  • Posts: 627
  • Joined: Sat Apr 13, 2013 5:38 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 11:47 am

Oh, and which ASIO driver?
Offline
User avatar

cwmod

  • Posts: 280
  • Joined: Wed Oct 30, 2013 5:16 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 12:24 pm

Hi Will,
ok I'm just double-checking. No, I used the correct Asio. Actually it was ext.out 9/10 (sorry), which goes to Asio 5L/R.
I'm on PCI here, so I'm using Asio Scope PCI in Ableton :)
I'll restarting now cause after loading + connecting Able & Scope the same error message showed up and I don't want this BSOD stuff again.
Short question before restarting: Java - I didn't copy the Java files which came with the bcmodular-scopesync-7d084ee.zip, because I don't know where to copy it. (Cycling'74/Max6.1/packages/bcmodular?)
Maybe this is the culprit?
Offline
User avatar

cwmod

  • Posts: 280
  • Joined: Wed Oct 30, 2013 5:16 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 12:29 pm

back again. just checked, I have the latest Java version.
Offline
User avatar

w_ellis

  • Posts: 627
  • Joined: Sat Apr 13, 2013 5:38 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 6:27 pm

Hi Roy,

Sorry for the slow response, I was out all day! Anyway, I'm very surprised that you had a BSOD and I wonder what caused it. Interestingly though, it wouldn't have been our code if you hadn't installed the Max java package already. I've updated the main post above to include a link to the ScopeSync wiki page which explains about where to install it etc.

Please let me know how you get on with that. If you're still having problems it would be great to know what versions of the various software you're running and specifically which ASIO Scope device/module. We recommend the ASIO-Flt or ASIO2-Flt ones running at 32bit for the best results.

Thanks,
Will

P.S. I'm not sure what the bcmodular-scopesync-7d084ee.zip file is. The up-to-date package is in the 0.975b BC Modular release that Simon posted a few days ago.
Offline
User avatar

sharc

Site Admin

  • Posts: 589
  • Joined: Thu Apr 11, 2013 12:02 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 6:35 pm

cwmod wrote:Hi w_ellis!
sorry I can't get it to work.
In Able, I loaded the m4l ss-waldorf patch, ok.
In Scope, I loaded the SSWaldorf modular patch, ok.
In Able, I configuered the output to ext 7+8, ok.
In Scope, I connected Asio 5L/R to the patch In1 and 2...
and then I got an error message in Able, lost all Asio connections and afterwards a BSOD.
Do you have an idea what I did wrong?


That's strange. ScopeSync has been tested quite thoroughly by Will with his XITE and myself with Scope PCI. Beyond that it's been available for testing in the Development forum for some time now and although there have been a few teething troubles during development, the latest version has been working great at this end.

The only thing I've noticed is that toggling the ScopeSync activate button on-off-on-off... on the SS panel can occasionally cause the ASIO to drop out. When this happens Scope ASIO usually just needs reselected as the Ableton audio device and then it should work OK again.

What you're describing certainly isn't the best. It would be good if we can find out what could be causing this. What version of Windows and Ableton are you running?

Screenshot-2014-03-11-09.42.25edit.jpg
Screenshot-2014-03-11-09.42.25edit.jpg (30.21 KiB) Viewed 10549 times


cwmod wrote:Bad that it doesn't work cause controlling Scope diretly in Ableton would be super cool!


It is 8-)

I've been using the ASIO1-32 Source 64 software IO with it and the resolution is awesome - it's also really easy to pick and choose MIDI CC assignments from the B-Control in Ableton so you can select a few parameters to control with 14bit CCs and leave the rest on regular CCs. Being able to record MIDI control as automation which can then be fine tuned to this extent is brilliant :)
Offline
User avatar

cwmod

  • Posts: 280
  • Joined: Wed Oct 30, 2013 5:16 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 9:02 pm

Hi Will and Sharc,
ok I found it, it was my very own Mixing device. :oops:
Tested it with Dynamic mixer - all seems ok. :P
Sorry for the trouble, I'll let you know how it goes.

(I think I have to make some changes on the "on same dsp" settings on the CwMixer)
Offline
User avatar

w_ellis

  • Posts: 627
  • Joined: Sat Apr 13, 2013 5:38 pm

Re: SS-Waldorf

PostThu Mar 13, 2014 9:06 pm

Good news! Look forward to hearing about how you get on!
Next

Return to BC Modular Patches

Who is online

Users browsing this forum: No registered users and 1 guest

cron